ilia24.gr
Τετάρτη, 12 Ιουνίου 2019 14:20

Ενδεικτικές απαντήσεις στο μάθημα «Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον» από το φροντιστήριο «Άλμα»

Ενδεικτικές απαντήσεις στο μάθημα «Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον»

ΘΕΜΑ Α

Α1.

1.     Σωστό

2.     Λάθος

3.     Λάθος

4.     Σωστό

5.     Λάθος

Α2.

Σχολικό βιβλίο σελίδα 56

«Επιλογή από τους μαθητές να περιγράψουν 4 λειτουργίες από τις 8 που αναφέρονται στο βιβλίο»

Α3. (α)

Χ>Μ

Χ

Κ

Μ

ΟΘΟΝΗ     Χ

4

4

9

ΨΕΥΔΗΣ

6

6

ΨΕΥΔΗΣ

8

8

ΑΛΗΘΗΣ

10

10

Α3. (β)

Χ>Μ

Χ

Κ

Μ

ΟΘΟΝΗ     Χ

5

5

0

7

7

ΑΛΗΘΗΣ

Α3. (γ)

Χ>Μ

Χ

Κ

Μ

ΟΘΟΝΗ     Χ

-1

-1

3

ΨΕΥΔΗΣ

1

1

ΑΛΗΘΗΣ

3

3

Α4.

α)

β)

Α5.

Αλγόριθμος Πολλαπλασιασμός_αλά_ρωσικά
   Δεδομένα // M1,M2 ακέραιοι //
   Ρ ← 0
   Όσο M2 > 0 επανάλαβε
      Αν M2 mod 2 = 1 τότε Ρ ← Ρ+Μ1
      M1 ← Μ1*2
      M2 ← M2 div 2
Τέλος_επανάληψης
Αποτελέσματα // Ρ, το γινόμενο των ακεραίων M1,M2 //
Τέλος Πολλαπλασιασμός_αλά_ρωσικά


ΘΕΜΑ Β

Β1.

(1) 0

(2) n

(3) ΨΕΥΔΗΣ

(4)  i

(5)      count + 1

(6) 3

(7) Αληθής

(8) Position

(9) i ß I + 1

(10)   done= Αληθής

Β2.

α)

(1) Η μεταβλητή υ δεν μπορεί να δεχτεί και τις 10 τιμές του πίνακα Ψ

(2) Η κλήση της συνάρτησης δεν μπορεί να γίνει με την χρήση της εντολής ΚΑΛΕΣΕ

(3) Ο αριθμός των τυπικών και των πραγματικών παραμέτρων στην παρένθεση δεν είναι ίσος αριθμητικά

(4) Ο τύπος της μεταβλητής υ δεν είναι του ίδιου τύπου με τον τύπο της τιμής  που επιστρέφει η συνάρτηση

(5) Η κλήση της διαδικασίας γίνεται πάντα με τη χρήση της εντολής ΚΑΛΕΣΕ

β)

Οι διορθώσεις αναγράφονται με κόκκινο χρώμα

(1)  Πßα(κ,θ)

(2)  γß α(μ, θ)

(3)  ΚΑΛΕΣΕ Β(π, μ, γ)

(4)  γ ß Α(μ, θ)

(5)    ΚΑΛΕΣΕ Β(π, μ, ρ[1])

ΘΕΜΑ Γ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ

! Ερώτημα Γ1

ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ: ΜΑΧ, COUNT_X, COUNT_M, COUNT_Y, VISITS, MAX_E

ΧΑΡΑΚΤΗΡΕΣ: VIDEO, TITLE, ΚΑΤΗΓΟΡΙΑ

ΑΡΧΗ

ΜΑΧ ß - 1

COUNT_X< ß 0

COUNT_M ß 0

COUNT_Y ß 0

! Ερώτημα Γ2

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ VIDEO

ΑΝ VIDEO <> “ΤΕΛΟΣ” ΤΟΤΕ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ VISITS

ΜΕΧΡΙΣ_ΟΤΟΥ VISITS>=0

! Ερώτημα Γ3

ΑΝ VISITS>MAX ΤΟΤΕ

ΜΑΧ ß VISITS

TITLE ß VIDEO

ΤΕΛΟΣ_ΑΝ


! Ερώτημα Γ4

ΑΝ VISITS >=1 ΚΑΙ VISITS<=100 TOTE

            COUNT_X ß COUNT_X + 1

ΑΛΛΙΩΣ_ΑΝ VISITS >=101 KAI VISITS <= 1000 TOTE

            COUNT_M ß COUNT_M+1

ΑΛΛΙΩΣ

            COYNT_Y ß COUNT_Y+1

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΜΕΧΡΙΣ_ΟΤΟΥ VIDEO = “ ΤΕΛΟΣ”

ΓΡΑΨΕ “Χαμηλή:”, COUNT_X

ΓΡΑΨΕ “Μεσαία:”, COUNT_Μ

ΓΡΑΨΕ “Υψηλή:”, COUNT_Υ

! Ερώτημα Γ5

ΜΑΧ_Ε ß COUNT_X

ΚΑΤΗΓΟΡΙΑ ß Χαμηλή”

ΑΝ COUNT_Μ > ΜΑΧ_Ε ΤΟΤΕ

ΜΑΧ_Ε ß COUNT_Μ

ΚΑΤΗΓΟΡΙΑ ß “ Μεσαία”

ΤΕΛΟΣ_ΑΝ

ΑΝ COUNT_Υ > ΜΑΧ_Ε ΤΟΤΕ

ΜΑΧ_Ε ß COUNT_Υ

ΚΑΤΗΓΟΡΙΑ ß “Υψηλή”

ΤΕΛΟΣ_ΑΝ

TΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΘΕΜΑ Δ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ

!Ερώτημα Δ1

ΜΕΤΑΒΛΗΤΕΣ

            ΑΚΕΡΑΙΕΣ: i, j, ΒΑΘ[40,6], ΤΕΜΡ1, ΣΒ[40], ΚΩΔ_Μ, ΚΩΔ_Π, ΒΑΘΜΟΣ

            ΧΑΡΑΚΤΗΡΕΣ: ON[40], ΤΕΜΡ2, ΑΠΑΝΤΗΣΗ

ΑΡΧΗ

! Ερώτημα Δ2

ΓΙΑ  i ΑΠΟ 1 ΜΕΧΡΙ 40

ΔΙΑΒΑΣΕ ΟΝ[i]

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6

Β[ i,j] ß0

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! Ερώτημα Δ3

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ ΚΩΔ_Μ, ΚΩΔ_Π

ΔΙΑΒΑΣΕ ΒΑΘΜΟΣ

ΑΝ ΒΑΘΜΟΣ > ΒΑΘ [ΚΩΔ_Μ, ΚΩΔ_Π] ΤΟΤΕ

ΒΑΘ [ΚΩΔ_Μ, ΚΩΔ_Π] ß ΒΑΘΜΟΣ

            ΤΕΛΟΣ_ΑΝ

            ΓΡΑΨΕ “Υπάρχει νέα λύση ΝΑΙ/ΟΧΙ”

            ΔΙΑΒΑΣΕ ΑΠΑΝΤΗΣΗ

ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠΑΝΤΗΣΗ = “OXI”

! Ερώτημα Δ4 (α τμήμα)

ΚΑΛΕΣΕ ΥΣΒ (ΒΑΘ, ΣΒ)

! Ερώτημα Δ5

ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 40

ΓΙΑ j ΑΠΟ 40 ΜΕΧΡΙ i ΜΕ_ΒΗΜΑ -1

ΑΝ ΣΒ[j] > ΣΒ[j-1] TOTE

TEMP1ß ΣΒ[j-1]

ΣΒ[j-1] ß ΣΒ[j]

ΣΒ[j] ßΤΕΜΡ1

TEMP2ß ΟΝ[j-1]

ΟΝ[j-1] ß ΟΝ[j]

ΟΝ[j] ßΤΕΜΡ2

ΑΛΛΙΩΣ_ΑΝ  ΣΒ[j] = ΣΒ[j-1] ΤΟΤΕ

ΑΝ ΟΝ[j]< ΟΝ[j-1] ΤΟΤΕ

TEMP2ß ΟΝ[j-1]

ΟΝ[j-1] ß ΟΝ[j]

ΟΝ[j] ßΤΕΜΡ2

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 40

            ΓΡΑΨΕ ΟΝ[i], ΣΒ[i]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! Ερώτημα Δ4 (β τμήμα)

ΔΙΑΔΙΑΚΑΣΙΑ ΥΣΒ (ΒΑΘ, ΣΒ)

ΜΕΤΑΒΛΗΤΕΣ

            ΑΚΕΡΑΙΕΣ: i, j, ΒΑΘ[40,6], ΣΒ[40]

ΑΡΧΗ

ΓΙΑ  i ΑΠΟ 1 ΜΕΧΡΙ 40

ΣΒ[i]ß0

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6

ΣΒ[i]ß ΣΒ[i] + ΒΑΘ[i, j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Σε PDF δείτε το εδώ

 

Επιμέλεια Απαντήσεων Μακρή Σταυρούλα Φροντιστήριο «Άλμα»

 

Πηγή : ilia24.gr

Προσθήκη σχολίου

Σιγουρευτείτε πως έχετε εισάγει όλες τις απαραίτητες πληροφορίες με το σύμβολο (*). Ο κώδικας HTML δεν επιτρέπεται.